XNA 3.0 Support

Nov 10, 2008 at 8:06 AM
Hi,

I have only started using XNA since 3.0 was released. I read in an earlier post that you would support 3.0 once it was released. As it is now released, have you any idea when it will be supported by this library? From reading about this library I cannot wait to use it :-)

Thanks,
Steve
Nov 11, 2008 at 12:35 AM
I'm fairly certin this works with xna 2.0. Everything in 2.0 works in 3.0 as far as i know
Nov 15, 2008 at 10:08 AM

Hey bob3695, you are correct. All I had to do was download the source and recompile the 2 DLLs. The three samples then worked although I did have to comment out the following 2 lines in each sample:-

                    effect.PointLights[0].Range = 10000;
                    effect.PointLights[0].Fallof = 4;

Does anyone know if these properties have been renamed in XNA 3 or just removed alltogether?

 

Nov 16, 2008 at 6:15 PM
Edited Nov 16, 2008 at 8:16 PM

Got a problem compiling XNAnimation_0.7.0.0_BETA2.

... took the following steps in vs express 2008 with xna 3.0:
a) Open project - XNAnimation Samples.sln
b) let Visual Studio Conversion Assistent do it's magic (no backup, due to the zip as a rollback method)
resulting protocol: no error
c) F5 (start project is AnimationControllerSample1 as shipped with the zip)
d) Error creating the binary... pressing No on the question wether to proceed with an older successful build
e) error message:
Error 5 Cannot find content processor "SkinnedModelProcessor". D:\Programming\XNAnimation_0.7.0.0_BETA2\XNAnimation Samples\Samples Content\Content\Models\EnemyBeast.fbx Samples Content

no changes made to the project - just unzipped it and hit the green button

but it may be caused by 3 warnings I get before the actual error - conflicts between different versions of the same assembly dependancy (relating to the 3 samples AnimationControllerSample1, AnimationControllerSample2 and CrossFadeBlendSample)

any ideas what I might need to change in order to get things working?

edit: seems like I can open it in xna 2.0 without problems.
but in xna 3.0 the name of the content processor changes from "Model - XNAnimation Processor" (xna 2.0) to "SkinnedModelProcessor" ... maybe it is named wrong within the source code? I'll go and check this out now.

Nov 17, 2008 at 8:16 AM
I also got these errors when downloading the main zip file. The problem is that this contains the 2 pre-compiled DLLs in the XNAnimation folder. These were built with XNA 2.0 so will not work with XNA 3.0.

  1. Therefore you need to download the Source Code here : http://www.codeplex.com/xnanimation/SourceControl/DownloadSourceCode.aspx?changeSetId=11975
  2. Then recompile the XNAnimation and XNAnimationPipeline projects that are contained in the source.
  3. Now take the 2 DLLs that are created in step 2 (XNAnimation.dll, XNAnimationPipeline.dll) and replace the 2 DLLs that came with the main download
  4. You should now be able to re-compile the XNAnimation Samples.sln (although you may need to comment out 2 lines from each sample - see my previous post in this thread) eg:-

                    //effect.PointLights[0].Range = 10000;
                    //effect.PointLights[0].Fallof = 4;

I did not have to make any other changes to the projects - all 3 three samples worked a treat.

Nov 22, 2008 at 3:16 AM
Bruno is busy nowadays, but I hope that he give the official support for XNA 3.0, how he said in the FAQ.
Jan 7, 2009 at 7:55 PM
I did as you have written it, but it still doesn't work..
Could someone please upload the DLLs working with 3.0?

Greez
Jan 19, 2009 at 8:36 PM
Hello Duallity!

I had the same problem, but you just have to download the source-code and the build it (f6). The included sample will work properly and hopefuly you can continue with you work.

Best regards
Carl
Jan 21, 2009 at 1:12 AM
Hi,

Could someone please help me to compile the dlls for C# Studio 2008. I have followed the above instructions and I can't seem to get this to work. I have opened the AnimationSample from the source code and build the solution. The XNAnimation.dll compiles but not the XNAnimationPipeline.dll. When I check for the pipeline.dll in the bin/release or debug folder the dll isn't there. I'm not sure what I could be doing wrong.

Also, I want to use this library on the 360. What do I need to do to compile the dlls for the 360 in XNA 3?

Thanks,

Wes
Jan 21, 2009 at 8:19 AM
If I remember right, the XNAnimationPipeline.dll isn't in the bin/x86, it's in the bin/Xbox folder.
For using it on the XBox: I tried it like in here: http://www.codeplex.com/xnanimation/Thread/View.aspx?ThreadId=30744
but as you can see, it didn't work for me yet.
Feb 24, 2009 at 11:30 PM

Here are XNA 3 compiled libraries. I hope it is ok to put them here, if not, please excuse me and delete them.

http://freefilehosting.net/download/45d9m

Mirrors:

http://www.usaupload.net/d/o597z6x5oao

ttp://www.filefactory.com/file/af2d7hc/n/XNAnimationLibrary_rar