Grayed Out Textures

Apr 11, 2009 at 6:50 PM

 

I just started using XNAnimation and am pretty excited at getting animated meshes to work.  I have a problem though.  The texture on my model looks light and sort of grayed out.  Here is a screenshot of the rectangular model  with the problem grassy texture next to some normal looking grass:

http://i163.photobucket.com/albums/t311/fancifulunicorn/textureproblem.jpg

Here are the values I have for the model in code:

// OPTIONAL - Configure material and light

 

effect.Material.DiffuseColor =

new Vector3(0.5f);

 

effect.AmbientLightColor =

new Vector3(0.9f);

 

effect.LightEnabled =

true;

 

effect.EnabledLights =

EnabledLights.Two;

 

effect.PointLights[0].Color =

Vector3.One;

 

effect.PointLights[0].Position =

new Vector3(100);

It seems like when I try to modify it past this the problem gets worse.  It looks more gray.  Is there something I'm not getting here?  I used blender and the custom fbx exporter for xna to make the model, animate, and UV map it.  Does it have something to do with materials in blender?  Why does it look fine using basiceffect but not with XNAnimation's SkinnedModelBasicEffect?  I noticed the example had two image files associated with PlayerMarine, one of them haveing diffuse in the title.  Does this have something to do with it?  Can I not just give a model a basic texture? 

Thanks a lot for any  help.

 

Aug 16, 2009 at 4:05 PM

I just ran into this issue as well.  I found the problem to be that the blender exporter was setting EmissiveFactor to 0.8 even through I had it setup for 0.0 in the blender material.  Having an emissive color of 0.8, 0.8, 0.8, is enough to make everything just about pure white on its own, so that's why the texture doesn't have much effect.  To override it, add this line to override the exported emissive color:

 

 

                    effect.Material.EmissiveColor = new Vector3(0.0f);

                    effect.Material.EmissiveColor = new Vector3(0.0f);

 

Apr 28, 2010 at 6:24 AM
Hi Matt, just wanted to say thanks for the post!! I have been trying to figure it out for weeks!! Seriously, thanks a lot.