gamestudio 3.1 and xnanimation

Jun 12, 2009 at 12:04 AM

Hey guys, I just installed xna gamestudio 3.1 and was planning on using xnanimation but i do not have a compiled version with 3.1. I tried to open the source projects myself and recompile but I get a ton of errors just to open with vs2008. Anyone have any luck compiling xnamination with gs3.1?

Jun 16, 2009 at 3:37 PM

I've uploaded a version for 3.0 (see this thread for info: http://xnanimation.codeplex.com/Thread/View.aspx?ThreadId=30744 ), you can find the download here: http://giggsy.3d-diggers.de/XNAnimation.zip

You might have more luck on converting this to a 3.1 project.
I'm not gonna move to 3.1 within the next 2-3 weeks, as we got to present our semester project and we dont wanna break anything ;)

But I'll post my results as soon as I did.

Jun 16, 2009 at 4:43 PM

Ok thanks, I actually did get it to compile with 3.1 but I have not tested it yet, Im working on a project for the dreambuildplay contest so I have to use 3.1.

Jun 16, 2009 at 10:02 PM

Hey giggsy wanted to thank you again because I did end up upgrading your posted project after all, which worked perfect.

Jun 17, 2009 at 7:44 AM

You're welcome, great to hear that it worked out!

Jun 17, 2009 at 6:06 PM
Edited Jun 17, 2009 at 6:09 PM

Hey Giggsy so I just tried to run everything on the xbox and I came across the same problem that was discussed here: http://xnanimation.codeplex.com/Thread/View.aspx?ThreadId=30744

I saw that the solution was to change line 24 of the AssemblyInfo.cs to read private static readonly string xboxPublicKeyTokens = "0c21691816f8c6d0";

but my line 24 is blank, when I added it there is an error with the word "string" saying expected class, delegate, enum, interface, or struct. Any thoughts?

 

Jun 18, 2009 at 8:02 AM

Careful, its not AssemblyInfo.cs, its AssemblyHelper ;)

If you're still using my provided 3.0 version, the changes actually should be done.
So maybe this is a 3.1 issue...

Jun 18, 2009 at 4:39 PM

Ah yes my mistake, so I found that file with your updated project and the line was correct, so I am thinking it is a 3.1 issue, perhaps there needs to be another token key for this assembly